Service won't activate

Service won't activate

Postby AustinM » Sun Mar 11, 2018 12:08 pm

So I've been using net10 for a while now, get a plan for a month, refill at the end of the month when the service runs out, repeat. I have had zero issues with this up until now. I entered my phone number correctly and bought a service plan, usually it activates right away but nothing happened my phone was still unusable. Some time passes and nothing happens, I've reset my phone several times and nothing. I then get a text saying I have net 10 verification code to my confusion. I eventually find out this is a code to make a net10 account which I had never done before. I make the account and check my device, the information is correct and it says that I have a service plan on that phone BUT I JUST WON'T WORK. I am getting very frustrated now and it is important that I get my service working on my phone. Somebody please help.
Posts: 2
Joined: Sun Mar 11, 2018 12:02 pm

Re: Service won't activate

Postby Net - Larry » Mon Mar 12, 2018 2:36 pm

Hi AustinM. My name is NET10 Larry. I read your post and I am sorry you’re having some problems. For further assistance, please check your forum inbox for a message. Click on "New Messages" beside User Control Panel to view your forum inbox. Thank you.
Net - Larry
Posts: 1870
Joined: Tue Oct 25, 2011 9:22 am

Return to Getting started, adding Airtime and other general NET10 discussions.

Who is online

Users browsing this forum: No registered users and 4 guests